IP Trade MIB |
|
| IT&Operations > System Monitoring > SNMP |
Every device and every variable implementing SNMP agent need to be identified by a unique object identifier. Identifiers of all IPTrade components are located in the IPTrade sub tree. IANA has authority to assign number to enterprise. IPTrade has received number 30191. So IPTrade sub tree is numbered: •iso.org.dod.internet.private.enterprise.iptrade (1.3.6.1.4.1.30191) Three main branches have been defined inside IPTrade sub tree. All main branches represent an IPTrade device type: •.iptrade.turret (.30191.1) •.iptrade.TPO (.30191.2) •.iptrade.tssva (.30191.3) Each main branch contains variables which are available in read only mode. Those variables are organized in groups representing run time modules. Turret MIB dependencies The imports which are made in turret MIB definition comes from SNMPV2-SMI MIB as it is defined in RFC-2578, SNMPv2-TC MIB as it is defined in RFC-2579 and SNMPv2-CONF MIB as it defined in RFC-2580. No other dependency exists for turret MIB. Some SNMP management application (for instance: OpManager) includes SNMPV2-SMI MIB which is different from RFC-2578. That may cause error on turret MIB parsing, ensure management application uses the right version of SNMPV2-SMI, SNMPv2-TC and SNMPv2-CONF . TPO MIB dependencies The imports which are made in TPO MIB definition comes from SNMPV2-SMI MIB as it is defined in RFC-2578, SNMPv2-TC MIB as it is defined in RFC-2579 and SNMPv2-CONF MIB as it defined in RFC-2580. No other dependency exists for TPO MIB. Some SNMP management application (for instance: OpManager) includes SNMPV2-SMI MIB which is different from RFC-2578. That may cause error on TPO MIB parsing, ensure management application uses the right version of SNMPV2-SMI, SNMPv2-TC and SNMPv2-CONF . TSS Virtual Appliance MIB dependencies The imports which are made in TSS Virtual Appliance MIB definition comes from SNMPV2-SMI MIB as it is defined in RFC-2578, SNMPv2-TC MIB as it is defined in RFC-2579 and SNMPv2-CONF MIB as it defined in RFC-2580. No other dependency exists for TSS Virtual Appliance MIB. Some SNMP management application (for instance: OpManager) includes SNMPV2-SMI MIB which is different from RFC-2578. That may cause error on TSS Virtual Appliance MIB parsing, ensure management application uses the right version of SNMPV2-SMI, SNMPv2-TC and SNMPv2-CONF . |